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Introduction 
 
RainScatter is a program designed to aid Radio Amateurs in making contacts on 
microwave frequencies by using precipitation particles as a scattering medium. It 
automatically downloads the latest radar images from the National Weather Service and 
their associated storm attribute tables to identify possible propagation paths between 
stations.  It is designed to eliminate some of the guesswork in identifying potential 
scattering regions.  I hope that it will foster interest in this exciting mode of propagation.   
 
I wish to extend my thanks to Gary Mohrlant (W0GHZ), Richard Bandla (VE3CVG), 
Dex McIntyre (W4DEX), Mike Reed (KD7TS), Larry Johnson (K0CQ), and everyone 
else who has provided me with feedback and bug-catching during the creation of this 
program.    
 
RainScatter is released under the GNU Public License.1  This ensures that the source 
code remains available for everyone, and that RainScatter shall forever be free for non-
commercial use. 
 
System Requirements 
 
 RainScatter can run on just about any platform provided that you have the Java 
Runtime Environment version 1.4.2 or later installed on your computer.  (JRE 1.4.1 will 
be able to execute the program, but will throw a runtime exception when attempting to 
download the storm tables.)   You also need an active internet connection to access the 
NOAA radar images (http, port 80) and Storm Attribute Tables (FTP, port 21).  This may 
mean that you need to configure your firewall to allow outgoing connections for these 
ports.  Because of the large image sizes, RainScatter also requires 1024x768 screen 
resolution or larger. 
 
Installation 
 
 Unzip RainScatterxxx.ZIP and place the contents in an empty directory.  The 
program executable is RainScatterxxx.jar.  The other files are files that are required by the 
program.  Do not edit them by hand: 
  
 alarmsettings.dat 
 RainScatter.dat 
 radarlocations.txt 
 stations.dat 
 quickhelp.html 
  
 If you do not have the JRE 1.4.2 or later you should download it from Sun’s 
website (http://java.sun.com).  In the Windows environment the Sun installer will also 
link the .jar extension with javaw, which will give "double-click" execution of .JAR files.  
                                                 
1 See the GPL website for more information (http://www.gnu.org/copyleft/gpl.html).  A copy of the GPL is 
contained in the ZIP archives with the program distribution.   



Do a software update on Mac OS 10.x to get the latest version of Java.   Once you have 
the JRE installed you can run the file by double-clicking the .JAR file.   You may also 
run the file from the command-line (on all platforms) by typing: 

java  -jar RainScatterxxx.jar <enter> 

Initial Setup 
 
 Once the main program window appears you should go to Settings > Radar List. 
This will bring up a window which contains all NOAA NEXRAD radar sites in the 
continental United States.  Place checkmarks by 1 to 10 radars in your area and press 
OK.  This will save your personal list of radar locations to disk.  You can change them at 
any time by going to this menu. 
 
Next, select your nearest radar location from the pull-down menu in the Radar Settings 
Panel.  This will download the current radar image for this location.   
 

 
Figure 1: Radar Settings Panel 

 
To set your home location, click the Set Home Loc button, type your six-digit grid 
locator in the box, and press <Enter>.  Alternatively you my press the Set Home Loc 
button and click your home location on the map to the left.  You may now do the same 
for the Set DX Loc button.  You may move these two locations at any time by going 
through this process.  Once set, you should go to Settings > Save Settings to record these 
positions for the next time you start the program. 
 

 
Figure 2: Station Information Panels 

 



Radar Controls 
 
 The NEXRAD radar images have two settings: distance and reflectivity.  The 
Shortrange view is the more detailed, but it limits its display to about 140 miles.  The 
Longrange view is less detailed but shows reflections out to about 240 miles.  The Base 
reflectivity image is produced by scanning for reflections just above the horizon (about 
0.5 degrees elevation).  The Composite image is produced when the radar scans though 
many elevation angles (up to 22 degrees) to analyze vertical storm structure.  This 
composite image is able to identify potential scattering media held aloft by strong 
updrafts that may not be visible in the base scan.2  Changing either of these settings will 
update the image accordingly.  Pressing the Update Map button will refresh the current 
view.  The top progress bar (below the View Storms button) will be active while the 
image is downloading. 
 
The Map Panel 
 
 The radar images are downloaded from the NOAA web server and display the 
reflectivity of the atmosphere on a color scale.3  The scale (on the left side of the image) 
can be in two ranges depending upon the scanning mode of the radar.4  The clear-air 
mode is a very sensitive mode that shows reflectivity up to 28dBZ.  This mode is used 
when the air is generally free of precipitation.  The precipitation mode is generally used 
when there is precipitation or the expectation of precipitation.  Its scale shows up to 75 
dBZ.  The very strongest echoes from severe thunderstorms are often in the 60-dBZ 
range, largely a result of highly-reflective hailstones.  Since the NEXRAD radar operates 
in the 9-GHz range, we may take this to be a reasonable approximation of reflectivity at 
the 10-GHz amateur band.5   
 The home and DX locations should be visible on the radar image (with a small 
yellow and white ‘X’s, respectively), provided that the selected radar includes those 
areas.  There is also a dashed purple line connecting the two with a larger purple ‘X’ 
indicating the midpoint between the locations.  Clicking the mouse on the map sets the 
scattering location.  In the Station Information Panels you will see the headings and 
distances to this point from both the home and DX locations.   Clicking on a storm 
therefore tells the user where to point the antenna.  Both station headings are provided in 
case the user needs to tell the other station where he should point his antenna when 
attempting the contact.6 
 Below the map one can see the scattering location as a six-digit grid square, the 
total path distance between stations via the scattering point, and the scattering angle as 
measured from the scattering point.  Since most 10-GHz stations use horizontal 

                                                 
2 It is also the scanning mode that the radar uses to generate the Storm Attributes Table. 
3 To see a map of radars and their respective pages, see http://weather.noaa.gov/radar/national.html . 
4 For an overview of the radars’ scanning modes, see National Weather Service’s radar FAQ page: 
http://weather.noaa.gov/radar/radinfo/radinfo.html . 
5 It is important to note that the map images themselves do not directly show at what altitude maximum 
reflectivity was measured.  For example, two neighboring storms may show 60dBZ reflections, however 
one of those storms may register that reflection at an altitude of 15,000 feet and the other at 35,000 feet.  
This information is provided in the storm tables. 
6 Headings are calculated by great-circle on a spherical earth. 



polarization, the strongest signals will be found when the scattering angle is closest to 
180 degrees (storm inline with the direct path) or 0 degrees (direct backscatter), and 
weakest when near 90 degrees.7  When the mouse cursor is over the map the grid square 
of the cursor’s location will appear at the bottom left. 
 
Using the Storm Table 
 
 Each NEXRAD radar produces a Storm Attribute Table that contains a list of all 
storms it can identify along with pertinent information such as height, reflectivity, 
movement, etc.  This table is embedded in a binary file that can be downloaded from the 
National Weather Service by FTP.8  RainScatter will download these files from all of the 
radars in your personal list (that is, up to 10 radars at once) and parse them into a master 
storm table.  This master table can be viewed at any time by pressing the View Storms 
button in the Radar Settings Panel.  This master table can be checked against a list of 
other locations to alert the operator when a storm appears above the horizon for two 
stations.   
 To utilize this feature you should enter a list of callsigns and grid squares in the 
Station List Window found under Settings > Station List.  The callsigns can be any text 
(usually a callsign, but it does not have to be) as long as it does not contain any spaces.  
The grid square must be a valid six-digit square.  The program will prompt you to fix it if 
it is not.  You can press the OK button to save changes.  The list will be automatically 
loaded the next time the program is started. 
 

 
Figure 3: Station List window showing a list of callsigns. 

                                                 
7 For a discussion of scattering angles and polarization, as well as rain scatter in general, see notes by Tom 
Williams, WA1MBA at http://www.wa1mba.org/10grain.htm . 
8 See the NWS Radar Product Central Collection Dissemination Service at 
http://www.nws.noaa.gov/tg/rpccds.html.  The Storm attribute table is appended to Product 37. 



 
 
 To download the storm table, press the Update Storms button in the Radar 
Settings Panel.  While the data is being transferred you should see the lower progress bar 
become active.  You can also monitor the progress of the download with the messages 
that appear beneath the Radar Settings Panel.  The progress bar will turn inactive once 
the transfer has ended.  If any storms in the master table are mutually visible between the 
home station and any stations in the list, those stations will have buttons in the Visible 
Stations Panel.  Likewise, if any storms are visible with the current DX location, there 
will appear a button labeled “DX”.  This list will update every time the storm table is 
downloaded. 

 
Figure 4: Visible Stations Panel showing that a storm is visible between the home location and 
K0SM/6, as well as the DX location. 

 Clicking one of the stations’ buttons will set the DX location to that station’s grid 
square and bring up the list of storms that mutually visible.  This list will appear in the 
Storm Table Window below the Visible Stations Panel.  It is set to show the most 
pertinent information about each particular storm.  You can view all attributes by using 
the horizontal scrollbar at the bottom of the window.  Clicking on a row in the table will 
set the scattering location to that storm’s location.  This allows the operator to read beam 
heading and other information for this storm.  To see the mutually visible storms with 
another station, just click on that station’s button. 
 

 
Figure 5:Typical large thunderstorm cell.  If station A is the home location, stations B and C would 
appear in the Visible Stations Window because they are all within the footprint of the storm top.  
Both A and B are in the footprint of the point of maximum reflectivity.  D is not visible to any of the 
stations because the storm is below D’s horizon. 



 
Figure 6: Overhead view of the previous figure. 

 One should realize that the radar images and storm tables are usually a few 
minutes old.  Since the same dataset is used to generate both the composite radar image 
and that radar’s storm table, the timestamp on the image tells the user how old the the 
data is.  Since storms move, the current location of the storm tower may have changed 
significantly, particularly on shorter paths.  Often the base-reflectivity image will have a 
newer image to help pinpoint the current location of the storm.  The user can then click 
on the image to get the beam heading.  Also, the storm tables keep track of a storms 
direction and speed, making it possible to extrapolate the current location.  This is not 
likely to be much of an issue over longer distances since the beam headings are not likely 
to change significantly. 
 

 
Figure 7: Example of Storm Table Panel showing mutually visible storm with DX location.   

 It is important to note that the NEXRAD radar only logs storms within a 140-mile 
range of its location (essentially what is displayed in the shortrange view).  If you wish to 
have the alarm alert you to a possible path you must have the potential area visible to one 
of the radars’ short-range views, and that radar must be in your personal list.  There are 
pockets of the country that are not visible to any radar’s shortrange view.  If you are 



planning a path that requires coverage of one of these areas, it may be best to watch a 
radar in your area set to the longrange view.  If it shows echoes in this area from a long 
distance, there is a good chance that you may be able to use them as a scattering medium. 
 To see the visible range of a storm, you can activate the one or both of the 
Footprints from Draw > Footprints menu.  Selecting Echo Tops will draw a circle that 
represents the horizon from the very top of the storm.  Any station inside of that circle 
can therefore see the top of the storm.  Likewise, selecting Max reflectivity will draw a 
circle showing the visibility from that storm’s most reflective point as measured by the 
reporting radar.  You can think of these circles as being analogous to the “footprint” of a 
satellite.  When enabled, these circles will appear anytime a storm is selected in the storm 
table. 

 
Figure 8: Echo-top circle in yellow (~6400 ft) and max-reflectivity circle (~2400 ft).  The dotted 

purple line shows the direct path between the stations with the purple ‘X’ showing the midpoint.  
This image is a result of clicking on the first storm in the previous figure. 

 
Using the Fisheyes 
 
 Enabling the Fisheyes (Draw > Fisheyes) is useful for investigating potential 
rain-scatter paths.  It will draw a circle around a station’s location showing the range for 
which a storm of a certain height will be visible.  For example, setting my home location 
to EN13vc and the DX location to EN19lu, I can enable the fisheye for 40,000 feet.  Two 
circles will be drawn, one around each location.  If a 40,000-ft storm appears inside a 
circle, that storm will be visible to that station.  The intersection of the two circles—the 
“fisheye”—shows where a 40,000-ft storm will be visible to both stations.  When 
planning long paths this feature helps the operator decide which radars need to be 
monitored for potential rain-scatter paths. 
 



 
Figure 9: Fisheye for 40,000 feet between EN19lu and EN13vc.  These two operators should monitor 

the Aberdeen, SD and Grand Forks, ND radars in their radar lists because their storm tables will 
cover this area. 

 
Auto-Update and Alarm 
 
 Automatic updating of the image and the storm table is accomplished by placing a 
check in the Auto checkbox in the Radar Settings Panel.  The updates interval is set by 
the number of minutes in the box below.  When the timer executes, it downloads a new 
image as well as the most recent storm table.9  If pop-ups are enabled in the Alarm 
Settings Window (available under Settings > Alarm Settings) a pop-up window will 
appear when any of the alarm conditions are met.   
 This feature has exciting possibilities for contests and overall general activity on 
the microwaves.  For example, if all operators in a region of the country monitor the same 
radars they will all be aware of the same potential paths at the same time.  Such a 
situation in a contest could result in several long microwave contacts that would 
otherwise have gone unrealized.  In the case of large thunderstorms it may even become 
possible for operators to call CQ because everyone knows where to point their antennas.  
One can imagine such a situation turning a lazy summer afternoon into a spactacular 
DXing event! 
  
Saving and Viewing Images 
 

                                                 
9 While only one image is downloaded, the storm tables for all of the radars in the user’s personal list will 
be downloaded. 



 Radar images may be saved to disk in JPG format by choosing File > Save 
image.  This will save only the raw radar image and not any of the graphics produced by 
the program itself (path lines or any of the circles).  A saved image can be opened by 
choosing File > Open Local File.  When loading a saved image, be sure to specify the 
range, reflectivity, and radar location in the panel to the right of the file viewer.  This 
ensures that the image is interpreted properly when the program overlays its graphics. 
 

 
Figure 10: File chooser showing the radar settings 

 
Interpreting the Storm Tables 
 
 The storm table presents information about each particular storm identified by the 
reporting NEXRAD radar.  RainScatter parses this information into a format that is useful 
for rain-scatter communication.    The NEXRAD radars have complex algorithms for 
detecting severe weather, such as TVS, MESO, and hail estimation.  This data could be 
useful for rain-scatter communications, so they are included in the table.  Probably the 
most immediately useful are the altitudes of maximum reflectivity and echo tops.  In 
addition, large hail may make communication possible on lower microwave frequencies 
because of the larger scattering particles.  This data is provided so that the Amateur Radio 
community can learn through experimentation. 

 
Attribute          Description 
 
Grid:    Location of the storm center. 
 
Top:    The maximum altitude at which the storm returns echoes of 18 dBZ or  
  greater.  This altitude is reported in thousands of feet.  
 



dBZ:  The maximum reflectivity of this storm at any altitude. 
 
Height: The altitude of maximum reflectivity in thousands of feet. 
 
Dir:  The direction this storm is moving, in degrees. 
 
Speed:  Speed at which this storm is moving in knots.  (Not maximum winds  
  within the storm) 
 
ID:  The alpha-numeric ID of this storm, assigned by the radar. 
 
TVS:  Tornadic Vortex Signature (possible tornado) 
 
MESO: Mesocylone (large-scale storm rotation) Signature.  This is often a marker  
  of severe thunderstorms. 
 
POSH:  The probability (%) of severe hail, as estimated by the radar. 
 
POH:  The probability (%) of hail, as estimated by the radar. 
 
MXSize: An estimate of the maximum size (in) of the hail. 
 
VIL:  An estimate of the amount of water in the storm tower in terms of kg  
  of liquid water per square meter.   
 
RAD:  The reporting radar’s callsign. 
 


